Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


20 Dicembre 2014 Postato da: DanyPPC
[TUTORIAL] Installazione OS3.9 su scheda C.F.
INSTALLAZIONE OS 3.9 su Compact Flash By DanyPPC v. 1.2

L'arrivo degli adattatori Compact Flash per l'IDE interna di A600/1200 ha permesso di dotare il nostro fido Amiga di una unità economica e dalle buone prestazioni in alternativa ai sempre
più rari harddisk IDE da 2,5 e 3.5". In questo tutorial spieghiamo come installare l'ultimo sistema operativo Amiga 68k su CF attraverso l'emulatore WinUAE.
Ricordiamo che l'OS 3.9 richiede un Amiga con Rom 3.1 e un quantitativo di Ram di almeno 8MB. Consigliata pure una scheda acceleratrice per prestazioni migliori.
Oltre al CD fisico od in formato ISO del 3.9 ci occorre il file Kickstart 3.1 ed i 6 dischi ADF del Workbench 3.1.

1. inseriamo la nostra nuova CF nel lettore Multicard del PC
2. apriamo una shell dei comandi con "WINDOWS + R" e digitiamo "cmd", lanciamo adesso DISKPART con permessi di amministrazione
3. da DISKPART diamo il comando "list disk", selezioniamo la CF (nel nostro caso il disco 7) e digitiamo il comando "Clean" per ripulire la scheda da qualsiasi formattazione precedente:
Immagine

4. lanciamo WinUAE con i diritti di amministrazione e configuriamo come segue:
Immagine
Immagine
Immagine
Immagine

5. alla sezione "Floppy drives" inseriamo il disco INSTALL 3.1 nel DF0: mentre con le opzioni in basso creiamo un "Emergency Disk" da inserire del DF1:
Immagine

6. alla sezione "CD &Hard drives" aggiugiamo la CF con l'opzione "ADD Hard Drive" senza dimenticare di selezionare l'unità in basso con il CD del 3.9 inserito:
Immagine

7. non dimentichiamo in "Expansions" l'opzione uaescsi.device e siamo pronti per partire:
Immagine

8. avviato il disco INSTALL 3.1 eseguiamo il fido HDToolBox
Immagine

9. da HDToolBox > Change Drive Type > Define New > Read Configurations > OK e ancora OK:
Immagine

10. adesso click su Partition Drive per creare le nostre partizioni, senza dimenticare di settare il valore di MaxTransfer ed il Block Size per ciascuna partizione.
In questo caso abbiamo creato una partizione di Boot da 500MB per l'OS ed una partizione DH1 da 3GB che formatteremo solo a S.O. già installato:
Immagine Immagine

11. tornati alla schermata iniziale click to Save Changes to drive ed infine EXIT:
Immagine

12. con F12 inseriamo stavolta il disco del Workbench 3.1, Reset e formattazione della prima partizione "DH0:NonDos"
Immagine Immagine

13. dal CD di installazione del 3.9 creiamo il disco di emergenza in DF1: dal quale fare poi il boot per l'installazione vera e propria del 3.9:
Immagine Immagine
Immagine
Immagine Immagine
Immagine Immagine

14. a questo punto togliete l'Emergency Disk ed il CD di installazione per fare il reboot e ritrovarvi nella nuova installazione del Workbench 3.9
dalla quale formattare finalmente l'altra partizione creata DH1:
Immagine Immagine

L'installazione del 3.9 infatti va sempre fatta su una partizione entro i limiti dei 2GB, tutto il resto dell'Harddisk va partizionato/formattato dopo
l'installazione finita del WB3.9 per permettere a SetPatch e vari comandi NSD di patchare lo scsi.device e poter riconoscere harddisk di grandi
dimensioni e poter così avere anche partizioni superiori ai canonici 4GB di limite vecchi OS Amiga.
Io comunque vi consiglio d creare sempre 3 o 4 partizioni per comodità.
In questa guida non è stato tenuto conto del possibile uso di altri FileSystem più avanzati. Questi ultimi (SFS o PFS) andrebbero installati da
HDToolBox con altra procedura non pertinente allo scopo di questa semplice guida.
Io ho comunque potuto verificare che l'adozione di filesystem di terzi genera un maggiore consumo di memoria, trascurabile se nel sistema
abbiamo installato un quantitativo sufficiente di memoria fast (richiesta dallo stesso OS 3.5/3.9).

Spero di aver fatto cosa gradita !

Modificato il 25/12/2014 alle ore 12:15:03

Commenti: 67  Aggiungi - Pagine: 1-2-3-4

Indice: Forum / HowTo

Pagine: - [1] -2-3-4-

Athlas

Post inviati: 545

Visulizza profilo Messaggio Personale
93.41.70.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 1
Athlas 21 Dicembre 2014    00:38:18

Bravissimo.

ottimo lavoro


http://www.fantasyedintorni.it



87.5.182.*** Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 2
ivan74 21 Dicembre 2014    11:51:17

Perche dici che gli HD da 2.5 e 3.5 sono sempre piu rari.


2.234.155.*** Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1667.0 Safari/537.36
Commento 3
cip060 21 Dicembre 2014    12:53:19

Hai fatto un GRAVE ERRORE!!!
Se si usano le CF si deve modeificare la stringa di riconoscimento adesso non ricordo cosa bisogna scrivere devo cercare ma appena puoi devi modificare la procedura per renderla PERFETTA!!


2.234.155.*** Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1667.0 Safari/537.36
Commento 4 in risposta al 2 di ivan74
cip060 21 Dicembre 2014    12:58:30

Citazione

Perche dici che gli HD da 2.5 e 3.5 sono sempre piu rari.




Infatti saranno vecchi e lenti ma se ne trovano di nuovi a prezzi talmente bassi
un 160 giga ma si trovano ancora da 80 che per amiga sono una follia (ma con quello che costano
ne ho preso su amazono uno da 160 giga IDE pata 133 a 15 euro circa!!
messo uno su playstation 2 e network adapter e gli ho installato centinaia di giochi!!
quelli da 2.5 pollici sono facilissimi da trovare anche con un semplice adattatore SATA IDE vanno benissimo sul 1200/600
Sopratutto se si vuole mettere tramite sdoppiatore ide sia hardisk che cdrom/masterizzatore
Ricordo che con la maggior parte di adattatori ide/CF hanno seri problemi per far funzionare anche il cdrom in cascata bloccando nel 95% delle volte tutto il sistema (Cosa che non avviene installando un semlice e hardisk)

Post inviati: 6455

Visulizza profilo Messaggio Personale
46.141.23.*** IBrowse/2.4 (AmigaOS 3.9; 68K)
Commento 5
amiwell79 21 Dicembre 2014    13:08:56

@cip

se ha lui ha funzionato cosi' perche' non dovrebbe andare tanto la cf e gia' stata sistemata con la prima installazione del wb 3.1!

Poi di hd se ne trovano in giro ma la comodita' della cf non ha euguali


support

https://www.actionaid.it/

https://www.amref.it/



2.234.155.*** Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1667.0 Safari/537.36
Commento 6 in risposta al 5 di amiwell79
cip060 21 Dicembre 2014    13:15:42

Citazione

@cip

se ha lui ha funzionato cosi' perche' non dovrebbe andare tanto la cf e gia' stata sistemata con la prima installazione del wb 3.1!

Poi di hd se ne trovano in giro ma la comodita' della cf non ha euguali





Sembra che funzioni ma i blocchi e file corrotti li avra'!!
Visto che e' un parametro specifico se si usano le CF perche' non metterlo e mettersi il cuore in pace ???
Io consiglio se uno non lo sa che lo faccia prima di mettere cose tipo importanti e che le perda in seguito dovendo rifare tutto perche' blocchi corrotti e file system bad block alla fine si deve rifare TUTTO

Post inviati: 6512

Visulizza profilo Messaggio Personale
151.54.47.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 7
DanyPPC 21 Dicembre 2014    14:26:06

Probabilmente ti riferisci al valore di MAXTRANSFER che deve essere settato a 0x0001FE00, non sono certo che sia necessario per le CF.
In ogni caso fai bene a segnalarlo come possibile causa di problemi.

Aggiorno la guida


A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.1.4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Post inviati: 6512

Visulizza profilo Messaggio Personale
151.54.47.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 8
DanyPPC 21 Dicembre 2014    14:52:22

FATTO !

Vogliate perdonare la lacuna, spero adesso vada bene.
Ne va del buon nome del Forum !


A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.1.4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
188.153.185.*** Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 9
Ower-World 25 Dicembre 2014    01:25:32

Sei un GRANDE, mi serviva proprio questa guida. E vaiiii...


Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
5.90.130.*** Mozilla/5.0 (Linux; Android 4.4.4; A0001 Build/KTU84Q) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.93 Mobile Safari/537.36
Commento 10
Ower-World 25 Dicembre 2014    04:03:14

Guida ottima, ma ho un grosso grossissimo problema, l'Amiga 600 non mi vede la cf da hdtoolbox, mentre win-uae si, sarà perché l'ho formattata in fat 16? Devo installare in effetti il 3.1 e poi più in là passerò al 3.9 ma sono rimasto bloccato, anche se installo il WorkBench con win-uae nel momento che devo salvare le modifiche apportate alla cf Windows mi restituisce l'errore che è impossibile apportare cambiamenti alla cf perché è in uso da un altro sistema (ovvero Windows). Avete qualche idea? Buon natale...



2.234.155.*** Mozilla/5.0 (Linux; Android 4.4.4; XT1032 Build/KXB21.14-L1.40) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/33.0.0.0 Mobile Safari/537.36
Commento 11
cip060 25 Dicembre 2014    09:07:35

Ancora con questo errore
Windows NON DEVE FORMATTARE HARDISK AMIGA
Se non lo riconosce sono cavoli suoi a lui NON DEVE interessare nulla di hardisk e partizioni Amiga

Post inviati: 6512

Visulizza profilo Messaggio Personale
151.74.190.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 12
DanyPPC 25 Dicembre 2014    09:44:45

Ho scoperto da poco che anche da Windows è possibile fare tutto, anche creare l'RDB Amiga con WinUAE, quindi non occorre per forza di cose l'Amiga Reale per inizializzare la CF come harddisk e creare le partizioni.
Basta procedere in questa maniera:

1. prendete la CF nuova (sicuramente formattata in FAT32) ed inseritela nel lettore MultiCard del PC
2. avviate una schell dei comandi con diritti di amministrazione premendo la combinazione "Windows + R" e successivamente digitate "cmd" + INVIO
3. da questa lanciate "Diskpart" sempre con diritti di amministrazione, si aprirà un'altra finestra dei comandi con Diskpart attivo
4. digitate il comando:

DISKPART> List Disk

Immagine

DISKPART> Select Disk 7 (nel mio caso)

e date il comando CLEAN

DISKPART> Clean

5. in questo modo eliminerete qualsiasi partizione attiva dalla CF
6. se infatti togliete la CF dal lettore e la reinserite vi chiederà di formattarla perchè non la riconosce come un volume compatibile, ma voi declinate la proposta
7. lanciate adesso WINUAE con i diritti di amministrazione in modo da poter aggiungere la CF come harddisk con la funzione "Add Hard Drive"
ed operare senza che Windows blocchi qualsiasi operazione sulla stessa da parte dell'emulatore


FATE ATTENZIONE con DISKPART, selezionate il disco corretto !

Ultima modifica avvenuta il 25/12/2014 alle ore 10:12:22


A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.1.4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Post inviati: 6512

Visulizza profilo Messaggio Personale
151.74.190.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 13
DanyPPC 25 Dicembre 2014    12:16:44

Aggiornata la guida con un metodo più semplice che non richiede l'impiego dell'Amiga fisico per tutta la procedura di installazione del 3.9


A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.1.4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.52.79.*** Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 14
carlo 25 Dicembre 2014    12:59:29

Bella guida ma DISKPART può essere pericoloso per i meno esperti, esistono molti tools grafici su Windows che fanno la stessa cosa, poi credo che comunque non serve fare questa operazione, HDToolbox da WinUAE riesce a piallara le partizioni, e sovrascrivere l'MBR con l'RDB di AMiGA OS, su una Macchina Windows anche con HDToolbox di AROS si può fare anche di più, tempo fa lo sperimentai, ecco il video:

AROS: HDToolBox Creare Partizioni HD USB Su Esterno (HDToolBox Create Partitions HD On External USB)

Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
5.90.130.*** Mozilla/5.0 (Linux; Android 4.4.4; A0001 Build/KTU84Q) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.93 Mobile Safari/537.36
Commento 15 in risposta al 11 di cip060
Ower-World 25 Dicembre 2014    15:11:51

Citazione

Ancora con questo errore
Windows NON DEVE FORMATTARE HARDISK AMIGA
Se non lo riconosce sono cavoli suoi a lui NON DEVE interessare nulla di hardisk e partizioni Amiga




Ho fatto una cavolata, lo ammetto, più tardi provo la guida di DANYPPC.


Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
2.40.177.*** Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 16
Ower-World 26 Dicembre 2014    18:42:26

Ragazzi, sono un principiante, lo so, non riesco a fare i cambiamenti alla cf con win-uae; quando da hdtoolbox clicco su salva per i cambiamenti effettuati, windows (xp) mi dice che win-uae non ha i privilegi di amministratore, lo avvio allora con i relativi privilegi ma poco dopo si riavvia il pc. hoi provato a formattare la cf in fat16 per farla vedere all'Amiga e da li procedere all'installazione con i floppy reali, ma niente da fare, la cf non la riconosce. Escludo l'incopatibilità, perche l'ho comprata su Amiga Kit. Conoscete solkuzione? Grazie a tutti (fratelli Amighisti)


Post inviati: 6512

Visulizza profilo Messaggio Personale
151.74.150.*** Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
Commento 17
DanyPPC 26 Dicembre 2014    19:44:09

Allora, inizializzare la CF direttamente da Amiga è la cosa più sicura e corretta. Io ho testato varie CF (Kingston, SanDisk, Dikom, Verbatim) con l'adattatore CF per IDE interno, e tutte funzionano correttamente.
Non ha importanza che sia formattata in FAT16 o 32, tanto HDToolBox ne distruggerà la struttura dell'MBR di Windows.
In ogni caso se hai inserito la scheda nell'Amiga, bootato da disco INSTALL 2.0/3.1 (se hai un Amiga600/1200), lanci HDToolBox e procedi con l'inizializzazione della scheda come indicato nel tutorial.
E' una cosa semplicissima. Se non ti funziona accertati di aver inserito correttamente l'adattatore x CF nella porta IDE interna.

Ricordati che nel caso dell'A600 devi avere le rom minimo versione 37.300 o 37.350
Le 37.299 erano in dotazione ai primi A600 e non supportano la IDE interna.

Ultima modifica avvenuta il 26/12/2014 alle ore 19:46:27


A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.1.4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
37.119.198.*** Mozilla/5.0 (Linux; Android 4.4.4; A0001 Build/KTU84Q) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.93 Mobile Safari/537.36
Commento 18
Ower-World 26 Dicembre 2014    21:45:49

Bene, domani pomeriggio proverò. Grazie


Ower-World

Post inviati: 140

Visulizza profilo Messaggio Personale
188.153.188.*** Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 19
Ower-World 27 Dicembre 2014    16:02:07

Ragazzi, l'adattatore non era inserito bene, però ennesimo problema: hdtoolbox mi vede la cf ma quando clicco su read configuration il sistema mi scrive "Unit is not a disk (type 7), procedo comunque alla modifica delle partizioni, posso cambiare tutti i valori e di conseguenza salvarli eccetto il Max Transfer; dopodiché il sistema mi chiede di riavviare, quando si riavvia mi viene questo messaggio:" Not a DOS disk in device DH0". Vi prego aiutatemi



2.234.155.*** Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Commento 20
cip060 27 Dicembre 2014    16:49:58

Consiglio vivamente di procurarsi un hardisk da 2.5 pollici ata da portatili e' la MIGLIORE COSA PER NON AVERE SBATTIMENTI DI BALLE

Pagine: - [1] -2-3-4-

Indice: Forum / HowTo

Utenti Online
Utenti registrati: 988 dal 1 Gennaio 2006
di cui online: 4 registrati - sampedenawa - gommaeacca - Mck - Kyle -
20 non registrati

Benvenuto all'ultimo utente registrato: Joe

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.36756491661072 secondi