Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Policy sito
Ricerca Google

Login

Nick


Password


10 Agosto 2014 Postato da: carlo
WinUAE Approda Su PPC: Installato Amiga OS4.1

Immagine




Come annunciato ieri mattina nelle News, finalmente Toni Wilen ha deciso di emulare il PPC, ora sarà possibile utilizzare i nuovi OS 4.X su PC. Fioccano le discussioni sul forum per segnalare a Toni Wilen i vari bug riscontrati, in QUESTA pagina web è possibile seguire o interagire con il bravo programmatore, allego i primi screenshot fatti dagli utenti del forum e la versione più recente di WinUAE (rilasciate 5 versioni in pochi giorni) by Toni Wilen

->Continua<-

Commenti: 852  Aggiungi - Pagine: 1...-39-40-41-42-43

Indice: Forum / Software Amiga in generale

Pagine: -1-2-3-4-5-6-7-8-9-10-11-12-13-14- [15] -16-17-18-19-20-21-22-23-24-25-26-27-28-29-30-31-32-33-34-35-36-37-38-39-40-41-42-43-

Post inviati: 11780

Visulizza profilo Messaggio Personale
212.14.142.*** Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0
Commento 281 in risposta al 276 di schiumacal
carlo 27 Agosto 2014    17:52:23

Citazione

@schiumacal
PROBLEMA
Seguendo il metodo di Carlo, cioe' quello di installare l'OS manualmente file per file su un HD virtuale, tutto funziona bene tranne che i driver Picasso, non riesco a configurarli e devo vedermi AmigaOS 4.0 alla risoluzione di 640x512 interlacciata a 256 colori.

A me non da 640x512, ma 800x600 24Bit

@Alecos
Che risoluzioni hai tu disponibili ?

Puoi allegare i tuoi file:
Screenmode.prefs
Picasso96Settings

Ultima modifica avvenuta il 28/08/2014 alle ore 07:31:04

Post inviati: 20

Visulizza profilo Messaggio Personale
178.211.81.*** Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 282 in risposta al 280 di Alecos
TheGenius 27 Agosto 2014    18:01:52



Grazie per la tua disponibilità Alecos!

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.240.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 283 in risposta al 281 di carlo
Alecos 28 Agosto 2014    10:35:44

Citazione

Citazione

@schiumacal
PROBLEMA
Seguendo il metodo di Carlo, cioe' quello di installare l'OS manualmente file per file su un HD virtuale, tutto funziona bene tranne che i driver Picasso, non riesco a configurarli e devo vedermi AmigaOS 4.0 alla risoluzione di 640x512 interlacciata a 256 colori.

A me non da 640x512, ma 800x600 24Bit

@Alecos
Che risoluzioni hai tu disponibili ?

Puoi allegare i tuoi file:
Screenmode.prefs
Picasso96Settings





Allora... poiché la attuale config di WinUAE non permette la condivisione delle risorse windows non ho modo di tirar fuori le prefs, ho provato a rendere condivisibile una cartella ma appena lo faccio mi va in palla l'emulatore, lo stesso se provo con l'opzione Add PC Drive at Startup... spero che Toni risolva al più presto questi inconvenienti... posso postare dei grab, che sto facendo...

Immagine

Carlo hai provato a copiare il driver Picasso IV da storage/monitors a devs/monitors?

Ciao


Immagine

Immagine

Post inviati: 11780

Visulizza profilo Messaggio Personale
212.14.142.*** Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0
Commento 284 in risposta al 283 di Alecos
carlo 28 Agosto 2014    13:49:29

Citazione

Allora... poiché la attuale config di WinUAE non permette la condivisione delle risorse windows non ho modo di tirar fuori le prefs, ho provato a rendere condivisibile una cartella ma appena lo faccio mi va in palla l'emulatore, lo stesso se provo con l'opzione Add PC Drive at Startup... spero che Toni risolva al più presto questi inconvenienti... posso postare dei grab, che sto facendo...

Sul problema credo ci stiano lavorando su, lo scambio file con Windows può essere fatto attraverso una ISO CD, io invece per scambiare i file con l'HardFile di OS4 uso Dopu4 con mio vecchio sistemaOS3 (vedi grabbata),però l'Hardfile in questo caso devi settarlo come UAE e non come IDE, altrimenti non viene visto.

Citazione

Carlo hai provato a copiare il driver Picasso IV da storage/monitors a devs/monitors?

Non serve copiare Picasso IV in Storage/Monitors perchè già presente in Devs/Monitors (vedi grabbata), forse quei due file richiesti risolvono?

Immagine

Ultima modifica avvenuta il 28/08/2014 alle ore 13:52:02

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.240.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 285 in risposta al 284 di carlo
Alecos 28 Agosto 2014    15:19:35

Citazione

Citazione

Allora... poiché la attuale config di WinUAE non permette la condivisione delle risorse windows non ho modo di tirar fuori le prefs, ho provato a rendere condivisibile una cartella ma appena lo faccio mi va in palla l'emulatore, lo stesso se provo con l'opzione Add PC Drive at Startup... spero che Toni risolva al più presto questi inconvenienti... posso postare dei grab, che sto facendo...

Sul problema credo ci stiano lavorando su, lo scambio file con Windows può essere fatto attraverso una ISO CD, io invece per scambiare i file con l'HardFile di OS4 uso Dopu4 con mio vecchio sistemaOS3 (vedi grabbata),però l'Hardfile in questo caso devi settarlo come UAE e non come IDE, altrimenti non viene visto.

Citazione

Carlo hai provato a copiare il driver Picasso IV da storage/monitors a devs/monitors?

Non serve copiare Picasso IV in Storage/Monitors perchè già presente in Devs/Monitors (vedi grabbata), forse quei due file richiesti risolvono?





Carlo, hai ragione ma perché non provi a fare una installazione pulita?

1) Ti crei un HD e poi te lo installi, partizioni, formatti usando OS3
2) Poi lo dai in pasto ad OS 4.0 Install CD e fai partire l'installazione da OS 4.0
3) Alla fine hai un sistema perfettamente funzionante e installato senza problemi...

PS: i passi di installazione riportati qui valgono anche per OS 4.0...


Immagine

Immagine

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.44.6.*** Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 286 in risposta al 285 di Alecos
carlo 28 Agosto 2014    16:40:11

Citazione

Carlo, hai ragione ma perché non provi a fare una installazione pulita?

1) Ti crei un HD e poi te lo installi, partizioni, formatti usando OS3
2) Poi lo dai in pasto ad OS 4.0 Install CD e fai partire l'installazione da OS 4.0
3) Alla fine hai un sistema perfettamente funzionante e installato senza problemi...

PS: i passi di installazione riportati qui valgono anche per OS 4.0...

Un po' per il mancato tempo, un po' per la fretta di vedere OS4, ho voluto fare l'installazione manuale perchè ho sempre fatto così. AMiGA, come nessuno, è un sistema Stand-alone e questo comporta la possibilità di impare tanto e meglio; io sul mio A4000 avevo la Picasso II, e configurare Picasso 96 no fu così difficile, i miei sistemi OS3 che uso su WinUAE hanno ancora quella configurazione e si sono autoconfigurati in automatico appena avviati dando da subito ottime risoluzioni.

Screnmode su OS3 (WinUAE)
Immagine

Ultima modifica avvenuta il 28/08/2014 alle ore 16:42:40

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
79.141.166.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 287
Alecos 28 Agosto 2014    17:53:13

Carlo ho appena controllato e non c'è nessuna configurazione per la Picasso IV... se clicco su PicassoMode mi appare una schermata vuota... c'è qualcosa che non va... un altro bug? In pratica non legge/carica la config di Picasso96Mode... devo investigare... adesso sto tentando una nuova installazione... vediamo se è un problema di OS 4.0 o di WinUAE...


Immagine

Immagine

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.44.6.*** Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 288
carlo 28 Agosto 2014    18:24:18

Riguardo le risoluzioni queste probabilmente dipendono anche dalla compatibilità Scheda video, nella schermata precedente per esempio su XP e una scheda Video ATI Radeon x1550 mi dava una risoluzione massima di 1280x1024 32Bit, mentre sul portatile con Win7 ed una scheda generica Video Intel HD Graphics mi da valori molto superiori 1600x900, guarda grabbata allegata. Picasso96Mode a primo acchitto è un programma non facile da capire, per renderti la vita più facile carica il file di settaggio "Picasso96Settings" che trovi nella Directory "Devs" e vedrai apparire i valori settati, eventualmente come detto prima posta i tuoi "Screenmode.prefs" "Picasso96Settings", Screenmode.prefs lo trovi in Prefs/Env-Archive/Sys/

Immagine





Ultima modifica avvenuta il 28/08/2014 alle ore 18:26:24

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.44.6.*** Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 289
carlo 28 Agosto 2014    19:21:44

Come dicevo bastava un semplice clikke su Picasso96Mode, ecco AmigaOS 4.0 con una risoluzione di 1600x1200

Immagine

Ultima modifica avvenuta il 28/08/2014 alle ore 19:37:20

Post inviati: 1525

Visulizza profilo Messaggio Personale
109.113.127.*** Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 290
schiumacal 28 Agosto 2014    20:02:13

Qualche giorno fa' avevo provato a copiare manualmente i driver e tutti i file annessi di Picasso dentro l'installazione di AmigaOS 4.0 per il semplice fatto che mi dava solo un paio di risoluzioni... e non riuscivo ad andare oltre la 640x512 a 256 colori.

Ebbene mi da' anche a me risoluzioni alte e diverse come appaiono sulla figura postata da Carlo, il problema e che se provo ad attivarne una di queste, naturalmente compatibile con la scheda video ed il display del mio notebook, dopo un riavvio si blocca tutto e non parte AmigaOS 4.0.

Quindi, almeno per quanto mi riguarda, io ho anche problemi con i driver Picasso.

Ora pero' mi manca il tempo per studiarci sopra...


Un giorno o l'altro risolverò equazioni di grado superiore a cinque.

Post inviati: 1525

Visulizza profilo Messaggio Personale
109.113.127.*** Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 291
schiumacal 28 Agosto 2014    20:03:49

Penso dipenda comunque da una incompatibilita' con alcune schede video e display...


Un giorno o l'altro risolverò equazioni di grado superiore a cinque.

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
79.141.167.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 292 in risposta al 288 di carlo
Alecos 29 Agosto 2014    11:33:38

Citazione

Riguardo le risoluzioni queste probabilmente dipendono anche dalla compatibilità Scheda video, nella schermata precedente per esempio su XP e una scheda Video ATI Radeon x1550 mi dava una risoluzione massima di 1280x1024 32Bit, mentre sul portatile con Win7 ed una scheda generica Video Intel HD Graphics mi da valori molto superiori 1600x900, guarda grabbata allegata. Picasso96Mode a primo acchitto è un programma non facile da capire, per renderti la vita più facile carica il file di settaggio "Picasso96Settings" che trovi nella Directory "Devs" e vedrai apparire i valori settati, eventualmente come detto prima posta i tuoi "Screenmode.prefs" "Picasso96Settings", Screenmode.prefs lo trovi in Prefs/Env-Archive/Sys/

Immagine





Forse ho trovato un modo per esportare le prefs, mi creo un floppy vuoto adf e ci metto i file... poi metto online il floppy... adesso sto reinstallando AmigaOS 4.0 da zero... voglio vedere se ho sbagliato qualche passo...


Immagine

Immagine

Post inviati: 1525

Visulizza profilo Messaggio Personale
109.113.50.*** Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 293
schiumacal 29 Agosto 2014    12:18:09

Attendo anch'io con ansia...


Un giorno o l'altro risolverò equazioni di grado superiore a cinque.

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
79.141.167.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 294 in risposta al 288 di carlo
Alecos 29 Agosto 2014    12:25:18

Citazione

Riguardo le risoluzioni queste probabilmente dipendono anche dalla compatibilità Scheda video, nella schermata precedente per esempio su XP e una scheda Video ATI Radeon x1550 mi dava una risoluzione massima di 1280x1024 32Bit, mentre sul portatile con Win7 ed una scheda generica Video Intel HD Graphics mi da valori molto superiori 1600x900, guarda grabbata allegata. Picasso96Mode a primo acchitto è un programma non facile da capire, per renderti la vita più facile carica il file di settaggio "Picasso96Settings" che trovi nella Directory "Devs" e vedrai apparire i valori settati, eventualmente come detto prima posta i tuoi "Screenmode.prefs" "Picasso96Settings", Screenmode.prefs lo trovi in Prefs/Env-Archive/Sys/

Immagine





Picasso96Mode non ha prefs... in devs non c'è nulla che Picasso96Mode possa caricare, nessun file di config... strano...


Immagine

Immagine

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.26.2.*** Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 295 in risposta al 294 di Alecos
carlo 29 Agosto 2014    14:19:45

Citazione

Picasso96Mode non ha prefs... in devs non c'è nulla che Picasso96Mode possa caricare, nessun file di config... strano...

Si in effetti di default su OS4 (almeno per l'installazione mia manuale) non c'è alcun file di settaggio, io avevo usato il file Picasso96Settings che avevo su OS3, per intenderci il settaggio Picasso II che vedi sulle schermate allegate sopra, poi dal menu (Attac setting to Board0: Picasso IV) di PicassoMode ho cambiato e scelto Picasso IV. Fatto questo ho prima salvato ill nuovo Picasso96Settings in DEVS e poi fatto il SAVE proposto dalla Gui, che subito mi ha proposto il riavvio; fatto il riavvio ho trovato le nuove risoluzioni. PicassoMode è un po' particolare da usare, per generare "Picasso96Settings" ex-novo non ricordo la procedura, ma per la creazione dei nuovi profili devi trascinare il Menu Item (Icona Cubo con su la freccia) sui vari campi e fare i vari settaggi per le varie risoluzioni.

Ultima modifica avvenuta il 29/08/2014 alle ore 14:21:22

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.212.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 296
Alecos 29 Agosto 2014    15:38:33

Amiga OS4 Prefs.adf

Poi screen della istallazione pulita su OS 4.0 Classic....

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine

Immagine


Immagine

Immagine

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.212.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 297
Alecos 29 Agosto 2014    16:02:16

Screen della configurazione compatibilità ethernet.device...

Immagine

Immagine

Immagine


Immagine

Immagine

Post inviati: 11780

Visulizza profilo Messaggio Personale
79.53.72.*** Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 298 in risposta al 288 di carlo
carlo 30 Agosto 2014    01:45:59

Citazione

Riguardo le risoluzioni queste probabilmente dipendono anche dalla compatibilità Scheda video, nella schermata precedente per esempio su XP e una scheda Video ATI Radeon x1550 mi dava una risoluzione massima di 1280x1024 32Bit, mentre sul portatile con Win7 ed una scheda generica Video Intel HD Graphics mi da valori molto superiori 1600x900


Riguardo questo dubbio sulla importanza della Schede Video del PC e l'effettiva influenza sulle risoluzioni., ho voluto chiedere il parere a Toni Wilen, che mi ha risposto così (anche se grossomodo ho capito, una traduzione più accurata mi farebbe molto piacere):

uaegfx: yes (only resolutions that your real video card support are listed)

rtg board hardware emulation: no, emulation can't prevent "illegal" modes just like monitor that can't support large resolutions can't prevent gfx card to output unsupported resolutions.

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.194.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 299 in risposta al 298 di carlo
Alecos 30 Agosto 2014    08:11:23

Citazione

Citazione

Riguardo le risoluzioni queste probabilmente dipendono anche dalla compatibilità Scheda video, nella schermata precedente per esempio su XP e una scheda Video ATI Radeon x1550 mi dava una risoluzione massima di 1280x1024 32Bit, mentre sul portatile con Win7 ed una scheda generica Video Intel HD Graphics mi da valori molto superiori 1600x900


Riguardo questo dubbio sulla importanza della Schede Video del PC e l'effettiva influenza sulle risoluzioni., ho voluto chiedere il parere a Toni Wilen, che mi ha risposto così (anche se grossomodo ho capito, una traduzione più accurata mi farebbe molto piacere):

uaegfx: yes (only resolutions that your real video card support are listed)

rtg board hardware emulation: no, emulation can't prevent "illegal" modes just like monitor that can't support large resolutions can't prevent gfx card to output unsupported resolutions.






Te lo spiego io... Quando vai in emulazione usando la scheda grafica virtuale di WinUAE (UAEGFX) hai le risoluzioni disponibili sul PC che ospita l'emulazione, mentre se emuli una scheda grafica non puoi sapere se le risoluzioni che userai sono supportate o meno in quanto trattasi di pura emulazione della scheda grafica con tutti i se e i ma del caso... se sei fortunato e la risoluzione che hai scelto è supportata la vedi in emulazione andare bene, mentre se scegli un'altra risoluzione magari non supportata potresti vedere lo schermo nero...


Immagine

Immagine

Alecos

Post inviati: 1615

Visulizza profilo Messaggio Personale
151.52.194.*** Mozilla/5.0 (Windows NT 6.0; rv:31.0) Gecko/20100101 Firefox/31.0
Commento 300
Alecos 30 Agosto 2014    11:27:17

IBrowse 2.4 parte poi però se tento di digitare qualche url si pianta... ma intanto si carica senza problemi...

Immagine

Bisogna mettere tutti i processi aperti da IBrowse in modalità non compatibile con JIT...


Immagine

Immagine

Pagine: -1-2-3-4-5-6-7-8-9-10-11-12-13-14- [15] -16-17-18-19-20-21-22-23-24-25-26-27-28-29-30-31-32-33-34-35-36-37-38-39-40-41-42-43-

Utenti Online
Utenti registrati: 988 dal 1 Gennaio 2006
di cui online: 4 registrati - sampedenawa - gommaeacca - Mck - Kyle -
19 non registrati

Benvenuto all'ultimo utente registrato: Joe

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.20170092582703 secondi