Mený principale
 Notizie
 Grafica
 Forum
 Links
 Retro Trailer
 Recensioni
 Modelli Amiga
 Storia Amiga
 Lista Utenti
 Contatti
Ricerca Google

Login

Nick


Password


                                                                                   
17 Agosto 2017 Postato da: divina
Workbench 3.1 -how to-
Da tempo sto pensando di rendere il Sistema Operativo dei computer Amiga il più possibile in sintonia con il proprio hardware, semplice ed ottimizzato, senza tanti fronzoli di terze parti utilizzando il Workbench 3.1 (che ricordo richiedere almeno il Kickstart 3.0 anche se è consigliato avere il Kickstart 3.1 per un supporto più completo con determinato hardware Amiga), con la possibilità di utilizzare games/apps 68k (e PPC) e se presenti schede video RTG (CGX4/P96 in base al modello di scheda video), schede audio AHI, schede ethernet (stack TCP/IP ed Envoy).
Realizzare ciò non è semplice perché richiede tempo ed esperenzia; pertanto direi che è interessante poter esporre in questo thread suggerimenti pratici per ottenere questo risultato finale, indicando di volta in volta anche un url dove poter reperire il software necessario ed in versione corretta (es

->Continua<-

Commenti: 356  Aggiungi - Pagine: 1...-14-15-16-17-18


Pagine: -1-2-3-4-5-6-7-8-9-10-11-12-13-14-15-16- [17] -18-

Post inviati: 922

Visulizza profilo Messaggio Personale
5.169.128.*** Mozilla/5.0 (Linux; Android 7.0; MHA-L29 Build/HUAWEIMHA-L29) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.107 Mobile Safari/537.36
Commento 321
GabrieleNick 28 Agosto 2017    02:17:38
Non scordiamoci MagicMenu! Semplicissima utility che permette di avere sempre a portata di click i menù contestuali della barra in alto andandoli a spostare in menu "pointer relative"

Immagine

Immagine

Immagine

Immagine

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.114.82.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 322
Amy - Mor 28 Agosto 2017    02:19:25
Io intanto ho installato una versione di MUI registrata truvata in rete...

Amiga rulla di brutto!!

cgugl

Post inviati: 1459

Visulizza profilo Messaggio Personale
2.40.239.*** Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Commento 323 in risposta al 320 di divina
cgugl 28 Agosto 2017    07:54:45
Citazione


Bisognerà fare diverse prove e sistemare meglio in modo più approfondito il discorso TD64 e NSD64 e serviranno anche degli esempi pratici con configurazioni hardware diverse a livello di controller, anche con controller


che altri problemi ha l'ide del 1200 rispetto al 4000?
Ti riferisci al fatto che due periferiche lavorano male ?
L'ide del 1200 non è bufferizzato non risolvi col driver, ma ti serve un cavo di pochissimi centimetri... è l'unica cosa che puoi provare a fare.

*****
Per il discorso TD64 e NSD64 c'è poco da dire.
Devi fare l'accoppiata:
Filesystem NSD64 + SCSI.deviceNSD
o
Filesystem TD64 + SCSI.device TD64

TD64 era la soluzione proposta da Phase5 e supportata dalle BlizzardPPC e CyberstormPPC. Naturalmente chi ha programmato lo scsi.device del WB 3.5 ha deciso di seguire un'altra strada chiamata NSD e rendere incompatibile la soluzione di Phase5 (altrimenti non si poteva vendere un nuovo workbench).

NSD dove si trova:
Tutti i filesystem e gli scsi.device presi da WB3.5 o 3.9 supportano solo l'NSD.

TD64 dove si trova:
Su aminet si trova il FastFileSystemTD64, eccolo quì:
http://aminet.net/package/disk/misc/ffstd64
Le cyberstorm e le blizzard ppc hanno il device fixato in memoria.
Per lo scsi.device del 1200 e del 4000 esiste solo una patch che applica il fix TD64, è questa quì:
http://aminet.net/package/disk/misc/frap_v1.0
e richiede la mmu

Post inviati: 36

Visulizza profilo Messaggio Personale
95.244.174.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Commento 324 in risposta al 303 di divina
gigi74 28 Agosto 2017    15:28:30
Citazione

Citazione

allora di p96 abbiamo la scelta:

c'è questo Unofficial Picasso96 2.1e (alpha) datato 1/11/2014
http://lilliput.amiga-projects.net/Picasso96.htm

e questo che è il vecchio di aminet datato 17/11/99:
http://aminet.net/package/driver/video/Picasso96



è perfetto, mentre per i CyberGraphX 4 42.0 RTG è necessario procurarsi il corrispondente CD-ROM o ISO (per esempio in EAB zone) e poi installare l' ultimo aggiornamento alla 42.7 R6 reperibili presso questi urls:
http://aminet.net/package/driver/video/CyberGraphX_4.3rc6
http://phase5.a1k.org/cgx.html

Ricordo che alcune schede video RTG sono solo CyberGraphX 4 altre solo Picasso96, alcune invece utilizzabili con entrambi i sistemi (di cui alcuni modelli hardware da preferirsi con una o l' altra modalità, per es. con la Cybervision643d preferisco i CyberGraphX 4, con la PicassoIV i Picasso96).





Ciao,

dovendo installare la bvision, avendo il CD originale CyberGraphX 4, l'aggiornamento 42.7 R6 di cui parli ti risulta essere un pacchetto cumulativo? Su phase5.a1k.org/cgx.html infatti si trova anche una versione RC4 e RC5 di CyberGraphX, oltre a una "CGX V3 for BVPPC".
Secondo te per la bvision come è meglio procedere? CD CyberGraphX 4 + solo l'aggiornamento alla 42.7 R6? Altro e quindi anche la "CGX V3 for BVPPC"?

Amiga 600 HD e Amiga 1200 Tower con Blizzard PPC 603/256Mb RAM BVision

Post inviati: 4348

Visulizza profilo Messaggio Personale
79.47.111.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36
Commento 325
DanyPPC 28 Agosto 2017    16:04:38
La versione CGX3 è più vecchia, si tratta di una versione free che si trova anche nel CD del 3.9.
La versione 4 è da preferire, e la sequenza di installazione parte dal CD CGX4 per poi proseguire con l'update 42.7.
Dopo installi i drivers Warp3D.

A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.9 BB4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Post inviati: 36

Visulizza profilo Messaggio Personale
95.244.174.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Commento 326 in risposta al 325 di DanyPPC
gigi74 28 Agosto 2017    18:57:47
Citazione

La versione CGX3 è più vecchia, si tratta di una versione free che si trova anche nel CD del 3.9.
La versione 4 è da preferire, e la sequenza di installazione parte dal CD CGX4 per poi proseguire con l'update 42.7.
Dopo installi i drivers Warp3D.




Amiga 600 HD e Amiga 1200 Tower con Blizzard PPC 603/256Mb RAM BVision

consulenza informatica ambito aziendale - appliance sicurezza - ambienti server multipiattaforma - servizi hosting - networking

Post inviati: 966

Visulizza profilo Messaggio Personale
217.133.133.*** Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:55.0) Gecko/20100101 Firefox/55.0
Commento 327 in risposta al 324 di gigi74
divina 28 Agosto 2017    21:04:53
Citazione

Ciao,

dovendo installare la bvision, avendo il CD originale CyberGraphX 4, l'aggiornamento 42.7 R6 di cui parli ti risulta essere un pacchetto cumulativo? Su phase5.a1k.org/cgx.html infatti si trova anche una versione RC4 e RC5 di CyberGraphX, oltre a una "CGX V3 for BVPPC".
Secondo te per la bvision come è meglio procedere? CD CyberGraphX 4 + solo l'aggiornamento alla 42.7 R6? Altro e quindi anche la "CGX V3 for BVPPC"?



ciao, inserisci il il CD-ROM di CyberGraphX 4 ed installi il tutto, poi decomprimi ( es. in RAM: ) l' archivio dell' aggiornamento alla 42.7 R6 e procedi con l' installazione da quest' ultimo; così facendo ti rtrovi CGX 4 aggiornato all' ultima versione.
Utilizza unicamente CGX4, lascia stare CGX3.

Commento modificato il 28/08/2017 alle ore 21:05:26


MorphOS 3.9-PowerMac G5 &&PowerMac G4 FW800 &&Pegasos2 G4 //AmigaOS4.1 FE - AMiGA4000T&D &&1200 &&600 &&500 - Mac Intel &&Powerpc &&68K - x64 servers -

Post inviati: 36

Visulizza profilo Messaggio Personale
95.244.174.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Commento 328 in risposta al 327 di divina
gigi74 28 Agosto 2017    23:11:08
Citazione

Citazione

Ciao,

dovendo installare la bvision, avendo il CD originale CyberGraphX 4, l'aggiornamento 42.7 R6 di cui parli ti risulta essere un pacchetto cumulativo? Su phase5.a1k.org/cgx.html infatti si trova anche una versione RC4 e RC5 di CyberGraphX, oltre a una "CGX V3 for BVPPC".
Secondo te per la bvision come è meglio procedere? CD CyberGraphX 4 + solo l'aggiornamento alla 42.7 R6? Altro e quindi anche la "CGX V3 for BVPPC"?



ciao, inserisci il il CD-ROM di CyberGraphX 4 ed installi il tutto, poi decomprimi ( es. in RAM: ) l' archivio dell' aggiornamento alla 42.7 R6 e procedi con l' installazione da quest' ultimo; così facendo ti rtrovi CGX 4 aggiornato all' ultima versione.
Utilizza unicamente CGX4, lascia stare CGX3.




domani provo e vediamo un po' il risultato! Grazie!

Amiga 600 HD e Amiga 1200 Tower con Blizzard PPC 603/256Mb RAM BVision

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.114.82.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 329
Amy - Mor 30 Agosto 2017    18:42:04
Piccola osservazione...E' veramente bello crearsi un WB 3.1 "fai da te" come si faceva negli anni 90, c'è però una cosa da sottolineare; Il mio WB 3.1 liscio e reattivo è già pregno di programmi e programmini per migliorarne le prestazioni ed avere qual minimo che serve che comincia a pesare... a me sembra che stia facendo una corsa per arrivare ad avere tutto quello che mi ha dato negli anni il 3.9 però sul 3.1, a questo punto ha veramente senso?Non sarebbe meglio installare il 3.9 e buona notte?In questo momento posso dire solo che ho riscoperto con piacere il MagicWB a dispetto delle stile GlowIcons del 3.9, ma mi manca l'usabilità immediata che avevo con quest'ultimo...

Amiga rulla di brutto!!

Post inviati: 4348

Visulizza profilo Messaggio Personale
79.47.111.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 330
DanyPPC 30 Agosto 2017    18:47:39
Ogni evoluzione è volta a migliorare le cose, al costo delle richieste ma col vantaggio dell'usabilità.
Anche io in passato ho installato un pò di tutto col 3.1, salvo poi passare prima al 3.5 e infine al 3.9 BB4.

Questo non pregiudica comunque la bontà di un prodotto, anche se espanso per soddisfare determinate caratteristiche più odierne.
In ogni caso la scelta è tua, qui trovi solo una guida per districarti col 3.1.

A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.9 BB4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

consulenza informatica ambito aziendale - appliance sicurezza - ambienti server multipiattaforma - servizi hosting - networking

Post inviati: 966

Visulizza profilo Messaggio Personale
217.133.133.*** Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17
Commento 331
divina 30 Agosto 2017    22:14:16
Molti dei passaggi indicati in questa "guida" che stiamo cercando di realizzare congiuntamente nel poco tempo libero che immagino abbia ciascuno di noi, sono applicabili anche ad AmigaOS 3.5 e 3.9 (es. la parte scsi direct td64 nds64, i devices, i filesystems ... molte utilities/tools/applicazioni citate ...etc...).
Inoltre ciò ci permette di creare l' OS a piacimento partendo da un OS funzionale e basico (ma pienamente supportato dal software 68k e PowerPc) con richieste minime (68000 con 1Mb per la sola installazione del WB3.1) e pertanto, scegliendo soluzioni ottimizzate, poter sfruttare al meglio modelli Amiga con hardware decisamente superiore.
Infine ciò ci permette di capire nel dettaglio tutti i passaggi fondamentali che sono apparentemente poco visbili/comprensibili nelle versioni successive al Workbench 3.1 e nel contempo permette di confrontarci in modo da apprendere reciprocamente qualcosa in più.

p.s.
dovrei riuscire a fare qualche prova pratica tra una decina++ di giorni

Commento modificato il 30/08/2017 alle ore 22:19:29


MorphOS 3.9-PowerMac G5 &&PowerMac G4 FW800 &&Pegasos2 G4 //AmigaOS4.1 FE - AMiGA4000T&D &&1200 &&600 &&500 - Mac Intel &&Powerpc &&68K - x64 servers -

Pegasus RyuSei Ken

Post inviati: 7566

Visulizza profilo Messaggio Personale
79.24.124.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 332
Seiya 31 Agosto 2017    12:00:21
a quanto pare su EAB hanno trovato una bella soluzione per migliorare per bene il 3.1
https://docs.google.com/spreadsheets/d/1-d1ME8urSP -6l5fH3ad3cuXpNCGUMaWeyjjdS47UrZ8/edit#gid=0

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.30.71.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 333
Amy - Mor 8 Settembre 2017    08:54:55
Ragazzi ho scaricato l'ultima versione della Icon.library ma per installarla basta che copi la icon.library in LIBS poichè è pieno di altro materiale.

Poi mi dite un buon lettore di ISO funzionante su 3.1
Stessa cosa per decomprimere ZIP cosa mi consigliate?

Aspetto vostre, grazie!

Amiga rulla di brutto!!

Post inviati: 4348

Visulizza profilo Messaggio Personale
82.60.213.*** Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 334
DanyPPC 8 Settembre 2017    10:34:50
C'è MountISO oppure il pacchetto DiskImage che permette di montare vari tipi di files immagine (Iso, Dms, ecc...)

A1200T OS3.9 BB4 PPC 240/060/256MB/BVision/IndivisionAGA MK2cr/BMon Switch/HD 80GB/DVD-RW/Drive 1,76Mb/Honey Bee CD32 Pad

A1200 OS3.9 BB4 ACA030/42/128MB/CF8GB/PCMCIA 4GB/PSX Adapter

A1200 OS3.9 BB4 030/50/64MB/CF16GB/PCMCIA 4GB/PSX Adapter

A1200 OS 3.1 2MB

A600 OS2.0 2MB/Gotek/Sega Pad

Jesus Lives

Post inviati: 3410

Visulizza profilo Messaggio Personale
46.141.23.*** NetSurf/3.6 (AmigaOS,m68k)
Commento 335
amiwell79 9 Settembre 2017    15:33:14
per gli zip e altri formati c'e' xadmaster e voodoox come interfaccia.

Amithlon OS 3.9 Dell Latitude C610 Laptop perfettamente compatibile
https://soundcloud.com/sabbate

Post inviati: 419

Visulizza profilo Messaggio Personale
80.104.88.*** Mozilla/5.0 (Linux; Android 6.0; ALE-L21 Build/HuaweiALE-L21) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.116 Mobile Safari/537.36
Commento 336
DrProcton 9 Settembre 2017    17:29:02
Io per decomprimere i file zip ho sempre usato semplicemente il programma unzip
http://aminet.net/package/util/arc/UnZip
Si usa da linea di comando, basta copiarlo in c:

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.30.71.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 337 in risposta al 336 di DrProcton
Amy - Mor 10 Settembre 2017    04:31:28
Citazione

Io per decomprimere i file zip ho sempre usato semplicemente il programma unzip
http://aminet.net/package/util/arc/UnZip
Si usa da linea di comando, basta copiarlo in c:


Idem! Solo che l'ho sempre usato con interfaccia pre-installato sul 3.9...Programmino semplice e pulito, magari potessi metterlo anche sul 3.1!!!

Amiga rulla di brutto!!

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.30.71.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 338 in risposta al 335 di amiwell79
Amy - Mor 10 Settembre 2017    04:31:58
Citazione

per gli zip e altri formati c'e' xadmaster e voodoox come interfaccia.



Di questi due mai sentito parlare...

Amiga rulla di brutto!!

Post inviati: 2135

Visulizza profilo Messaggio Personale
185.30.71.*** Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Commento 339 in risposta al 334 di DanyPPC
Amy - Mor 10 Settembre 2017    04:32:30
Citazione

C'è MountISO oppure il pacchetto DiskImage che permette di montare vari tipi di files immagine (Iso, Dms, ecc...)



Cosa mi consigli sul 3.1?

Amiga rulla di brutto!!

Jesus Lives

Post inviati: 3410

Visulizza profilo Messaggio Personale
46.141.23.*** NetSurf/3.6 (AmigaOS,m68k)
Commento 340
amiwell79 10 Settembre 2017    11:26:37
diskimage senza ombra di dubbio, poi per gli archivi xadmaster che trovi su aminet e la stessa che usa il 3.9, c'e' anche il key file da mettere in s:, voodoox sempre su aminet e' un'interfaccia grafica che sfrutta xad, fatti un giro su aminet, installi e poi ci fai sapere, queste sono ottime soluzioni.

Amithlon OS 3.9 Dell Latitude C610 Laptop perfettamente compatibile
https://soundcloud.com/sabbate

Pagine: -1-2-3-4-5-6-7-8-9-10-11-12-13-14-15-16- [17] -18-

Utenti Online
Utenti registrati: 945 dal 1 Gennaio 2006
di cui online: 4 registrati - ilBarbax - divina - Ozzyboshi_2 - DrProcton -
12 non registrati

Benvenuto all'ultimo utente registrato: Revrik76

© Amigapage 1998 - 2007 - Sito italiano dedicato alla piattaforma Amiga ed evoluzioni varie.
Struttura del sito interamente ideata e realizzata da Marco Lovera e Alessandra Lovera - Tutto il materiale inserito all'interno del sito Ť dei rispettivi autori/creatori.
E' assolutamente vietata la riproduzione o la manipolazione di tutti i contenuti o parte di essi senza l'esplicito consenso degli amministratori e degli autori/creatori.

Eseguito in 0.11607789993286 secondi